1

I am getting below issues while accessing SSRS. Can anyone let me know if you have faced this issue before.

The RSReportServer.config file has been modified.

Report ServerWindows Service (MSSQLSERVER) cannot connect to the report server database. The value for UrlRoot in RSReportServer.config is not valid. The default value will be used instead.


library!DefaultDomain!2b94!12/02/2016-19:48:43:: w WARN: Initializing UrlRoot to default value of '' because it was incorrectly specified in Configuration file as ''.


INFO: Registered url=http://+:81/Reports/, vdir=/Reports, pdir=C:\Program Files\Microsoft SQL Server\MSRS12.MSSQLSERVER\Reporting Services\ReportManager.


library!DefaultDomain!4c0!12/01/2016-18:35:35:: e ERROR: Throwing Microsoft.ReportingServices.Library.ReportServerDatabaseUnavailableException: , Microsoft.ReportingServices.Library.ReportServerDatabaseUnavailableException: The report server cannot open a connection to the report server database. A connection to the database is required for all requests and processing. ---> System.Data.SqlClient.SqlException: Cannot open database "ReportServer" requested by the login. The login failed.

I clicked the "test connection" button in the Reporting Services Configuration Manager and it succeeds.

  • it says Cannot open database "ReportServer" requested by the login. do you have proper connectivity and login can access the database. – Kin Shah Dec 2 '16 at 15:08
  • Yes @Kin,I have proper access to service account used by ssrs.DBowner and RSexec role. – SQLBoy Dec 2 '16 at 15:16
  • The error is fairly clear, you have an incorrect database, and an incorrect urlroot. Could you open Reporting services Configuration manager and fix your settings using the GUI (there is a test button I believeà – Tom V Dec 2 '16 at 15:42
  • Looks like your RSReportServer.config is corrupt or has been changed. – WEI_DBA Dec 2 '16 at 15:42
  • Is this ok or should I change http://+:81/Reports/.Please let me know if I Re-Install issue might fix. – SQLBoy Dec 2 '16 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.