I am currently restoring a database and I tried to restore the database three times. The third time I succeeded but unfortunately it seems that the other two attempts at restoring the database are still running but never finish.

I have these two blue windows on the pgAdmin screen which I can not remove or stop executing. I tried a lot of things, I even uninstalled PostgreSQL two times but the restoring windows appeared again.

I am using Windows 8 and PostgreSQL 9.6.

enter image description here

  • Do you see multiple pgAdmin 4 processes in Task Manager? Commented Dec 7, 2016 at 14:02
  • Thank you for your answer. No there is just one process for pgAdmin 4 in Task Manager.
    – Amaru
    Commented Dec 7, 2016 at 15:38
  • It sounds then as a bug. I think your best idea is to report it. Also, have you tried to uninstall pgAdmin 4 itself? Hopefully it cleans up after itself. Commented Dec 7, 2016 at 16:10
  • Yes I uninstalled everything, well I at least tried to. I will report it thank you though.
    – Amaru
    Commented Dec 7, 2016 at 17:34
  • I had the same problem and I took the simple way, I delete the server from pgAdmin and then I created it again and thats it, no more infinite back up precesses. Commented Sep 19, 2017 at 16:30

3 Answers 3


I had the same problem and this helped me to solve it:

SQL command to clean job queue in pgAdmin 4

I just had to uninstall pgAdmin, delete all the files on C:Program Files directory and in App Data directory, as well.

  • Why not only the file the linked answer mentions? Commented Dec 12, 2016 at 9:06
  • That's actually a good one. I have started with deleting the installed files so I had it little bit messy afterwards. That's why I did delete actually all the files and started everything from the scratch. Commented Dec 13, 2016 at 6:20
  • It can help, to delete just the one file in App Data directory. Commented Dec 13, 2016 at 6:20
  • because deleting the file this will remove all the setup of PGAdmin (e.g. stored servers and connections). @PavelReissmann thx for the great tip!
    – Markus
    Commented Jan 15, 2019 at 16:16
  1. Close pgAdmin.
  2. Kill the process (pg_dump.exe) from Task Manager window.
  3. Open pgAdmin and click on "Click here for details" in the blue-popup-window.
  4. Close the details-popup-window opened.
  • I had to do an intermediate step between 2 & 3: renaming/moving the file it tries to import. Next time you open PGAdmin 4 the job fails immediately
    – Markus
    Commented Mar 1, 2018 at 15:01

You can just delete this file C:\Users\YourUsername\AppData\Roaming\pgAdmin database file but the AppData is a hidden directory , you type %AppData% in the start in windows , you will directed to Roaming folder .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.