1

Background:

Windows Server 2016 Core
SQL Server 2016 Enterprise (obviously 64-bit)
Windows Failover Cluster
SQL Failover Cluster

I am attempting to connect to SQL Server Configuration Manager via my local Computer Management connecting to the database server. I expand Services and Applications and click on SQL Server Configuration Manager. However, this is the error message I see:

Connection failed. Cannot connect to WMI provider. You do not have permission or the server is unreachable. Note that you can only manage SQL Server 2005 and later servers with SQL Server Configuration Manager. Invalid namespace [0x8004100e]

I have tried this in the command prompt:

mofcomp "%programfiles(x86)%\Microsoft SQL Server\130\Shared\sqlmgmproviderxpsp2up.mof"

Which then says:

MOF file has been successfully parsed Storing data in the repository... Done!

Then I restarted WMI service, closed Computer Management, and reopened it. And I got the same error.

Does anyone know how to resolve this?

Thank you!

P.S. - I have posted this on another forum a few days ago and no one could help me resolve this issue

Update 1: I have turned off the firewalls on both client and server and attempted to connect to Configuration Manager which gave me the same error message

Update 2: My user account has domain admin privileges

Update 3: I ran the Get-WMIObject command and got SystemDirectory, BuildNumber, RegisteredUser, SerialNumber, and Version information so I'm guessing that I am allowed to access WMI remotely?

Update 4: I have SQLServerManager13.msc (located in the server's C:\Windows\SysWOW64) and attempted to open it on my local machine which gave me the same WMI error.

Update 5: I ran SQL Server repair on both SQL nodes (still same message)

Update 6: I ran winmgmt /verifyrepository and winmgmt /salvagerepository and both stated that the WMI repository is consistent

  • did you ever find a solution to this ? – Aousaf rashid Jul 17 '18 at 10:04
  • Yes. You need to have SQL Server 2016 installed on your local machine. Then you can use Computer Management to connect to your remote SQL Server Configuration Manager stuff. – dajonx Jul 18 '18 at 13:35
0

Symptoms On a 64-bit computer, you install an instance of the 32-bit (x86-based) version of Microsoft SQL Server. On the same computer, you install an instance of the 64-bit version of SQL Server 2008. If you then uninstall the 64-bit instance, you receive the following error message when you open SQL Server Configuration Manager:

Cannot connect to WMI provider. You do not have permission or the server is unreachable. Note that you can only manage SQL Server 2005 and later servers with SQL Server Configuration Manager. Invalid namespace [0x8004100e]

This problem also occurs if you uninstall the 32-bit instance, and you then open SQL Server Configuration Manager. Cause This problem occurs because the WMI provider is removed when you uninstall an instance of SQL Server. The 32-bit instance and the 64-bit instance of SQL Server share the same WMI configuration file. This file is located in the %programfiles(x86)% folder. Workaround To work around this problem, open a command prompt, type the following command, and then press ENTER: mofcomp "%programfiles(x86)%\Microsoft SQL Server\number\Shared\sqlmgmproviderxpsp2up.mof" Note For this command to succeed, the Sqlmgmproviderxpsp2up.mof file must be present in the %programfiles(x86)%\Microsoft SQL Server\number\Shared folder.

The value of number depends on the version of SQL Server:nnn

Microsoft SQL Server 2012 110 Microsoft SQL Server 2008 R2 100 Microsoft SQL Server 2008 100 Microsoft SQL Server 2005 90 After you run the Mofcomp tool, restart the WMI service for the changes to take effect. The service name is Windows management Instrumentation.

Status Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

0

Well, it's nice that if you have verified that what you're trying to access exists and is reachable, it's a permission issue.

A couple things I'd check: even though you are domain admin, you still might run into permission issues as I have had weird things like that happen. One thing that may help is locating the folder that contains the files you need and explicitly adding your account w/ full control, which should apply to all of the child files and folders within.

The other question to ask is what account is trying to access it? Is the ms sql service account the one trying to access it and if so, does THAT account had the necessary permissions to the folder/files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.