0

I have an odd problem. The company has used an ODBC connection for a desktop MDB program to connect to SQL Server. The ODBC connects using a SQL Server account to authenticate. It has worked without issue in the past.

Recently, it appears any new domain account does not connect. They always fail for an connection timeout error. I've tried creating brand new account, I've tried creating an account by "Copy as" and they still get a timeout error.

One additional twist, the first time I discovered this error, last week, was when I was moving a user to a different computer. The ODBC connection worked on her old computer but when logging on the new one, it timed out but still worked on her old computer. I also tried logging the user in on MY computer and her profile does a timeout.

I've tried rebooting the Domain Controller as well as the SQL Server. No changes on the network or any server.

  • if You use SQL Server account - it must not be affected by DC, did You can connect to SQL Server without application? (Management Studio or telnet to 1433 from new computer)? – a_vlad Dec 12 '16 at 1:36
  • I tried the telnet route and tested first from a computer/profile that I know works. I used the command " o <server name> 1433 " and I got an error "could not open connection to the host" but this is from somewhere the ODBC works. So, I assume I an not doing the telnet right? – creed Dec 12 '16 at 1:53
  • I'm not sure if it helps, but I installed SQL Server Management Studio and tried to connect from a working profile. It erred for: Connection Timeout Expired. The timeout period elapsed while attempting to consume the pre-login handshake acknowledgement. This could be because the pre-login handshake failed or the server was unable to respond back in time. The duration spent while attempting to connect to this server was - [Pre-Login] initialization=13497; handshake=14491; (.Net SqlClient Data Provider) – creed Dec 12 '16 at 2:11
  • let go from server side - what protocol enabled on SQL Server? You can use SQL Server Configuration Manager -> SQL Server Network Configuration for this – a_vlad Dec 12 '16 at 2:15
  • 1
    TCP/IP - enabled, correct? inside TCP/IP - check - all interfaces enabled ("Yes"), port (at the end - IPAll) - 1433, correct? Firewall - port open? – a_vlad Dec 12 '16 at 2:22
1

I found a solution to the problem, but not sure why it works. I added an inbound Windows Firewall rule on the server, for port 1433 and the users in question can connect. Not sure why this affected a couple users and not 20 others, but at least it gets the spotlight off me! Thanks for everyone's input.

0

I had similar issue when a computer was upgraded. The default timeout had been 60 for the query in Access and worked, but I had to extend the timeout to 200.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.