-1

I have a newly inherited SQL Server that was installed and setup by our Windows Administrators. I am able to remote into the box and run SSMS using my network credentials. However, I am not able to use SSMS on my local computer to connect to the SQL Server. Here is the message that I receive:

"A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - The wait operation timed out.) (Microsoft SQL Server, Error: 258)"

Running SSMS 2012 Windows 7 Remote SQL Server 2012 64-bit

Here is what I have tried and looked into:

  • The SQL Server is running. All protocols are enabled and TCP/IP is listening on the default port.
  • The SQL Server Browser is running.
  • My network credentials have been added to the SQL Server with sysadmin permissions.
  • SQL Server is set to allow remote connections to the server.

I have asked our Windows Admins to look into Firewall settings. Is there anything else that I can check?

  • If you RDP into the server and run SSMS can you see anything in the SQL or OS logs? Failed login attempts? Assuming they are being captured. – nkdbajoe Dec 19 '16 at 17:00
  • Well I looked into the logs and could not find any login actions recorded. Turns out the Login Auditing was set to 'None' ... OMG SMH. I turned that on and tried to login. Received the same error message but nothing was logged. Do I need to restart the SQL Server after changing the Login Auditing setting? – S. Lloyd Dec 19 '16 at 17:07
  • Yes you need to recycle SQL. I just tried this on our SQL 2012 test server and it didn't start tracking until I bounced the service. – nkdbajoe Dec 19 '16 at 17:28
  • How is login auditing supposed to help if the client cannot even find the server? – mustaccio Dec 19 '16 at 19:16
0

Turns out the Windows Administrators had to add a Firewall rule on the server. Had to allow connections from SSMS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.