1

So I'm having a little trouble with a BRAND new VM I just created today to test a Galera Cluster.

What I have done so far is...

  1. Download and install the latest CentOS 7 in a VM.
  2. Install open-vm-tools and configure SSH
  3. Install MariaDB Repo and install MariaDB 10.1 via

        cat << 'EOL' >/etc/yum.repos.d/MariaDB.repo
        # MariaDB 10.1 CentOS repository list - created 2016-12-21 16:21 UTC
        # http://downloads.mariadb.org/mariadb/repositories/
        [mariadb]
        name = MariaDB
        baseurl = http://yum.mariadb.org/10.1/centos7-amd64
        gpgkey=https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
        gpgcheck=1
        EOL
        yum install MariaDB-server MariaDB-client
    
    1. Now I get this error, but I am able to get to the MariaDB CMD Prompt which says its running, but I can't have this error on a brand new setup.

      [root@localhost ~]# mysql -uroot
      Welcome to the MariaDB monitor.  Commands end with ; or \g.
      Your MariaDB connection id is 2
      Server version: 10.1.20-MariaDB MariaDB Server
      
      Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others.
      
      Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
      
      MariaDB [(none)]> exit;
      Bye
      [root@localhost ~]# /etc/init.d/mysql status
      ERROR! MySQL is running but PID file could not be found
      
1
  • I've tried upgrading every package on the VM post install of MariaDB, going to try a "pre" upgrade and then install. Thankfully I took a "Vanilla" Snapshot before installing MariaDB! Commented Dec 21, 2016 at 16:37

1 Answer 1

0

Seems the issue was how it is started.

Using the following, all is well!!

[root@sql ~]# systemctl start mariadb.service
[root@sql ~]# systemctl enable mariadb.service
[root@sql ~]# /etc/init.d/mysql status
SUCCESS! MySQL running (920)

So don't use /etc/init.d/mysql start as stated in the install guide...

https://mariadb.com/kb/en/mariadb/yum/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.