0

The listener has started correctly and its status shows OK!

I enter the correct IP address of the server in the listener.ora file, not localhost.

But when I try to connect to my database by entering the following in SQL Developer:

user: system
password: *******

host: 54.215.5.46
port: 1521
SID: orcl

I get this error:

Statut : échec -Echec du test : Erreur d'E/S: The Network Adapter could not establish the connection

I think that I need to open the 1521 port but I don't know if this is the problem?

1

You need to check the following in-order to connect to remote database:

  1. Make sure server is accessible from client side, easiest way to do it by using ping command to verify.
  2. There is a connection between host and server using a specific port, you can use telnet command to verify.
  3. Enable the instance listener to be listening on an IP address not localhost.
  4. Database is running
  • Step 1 is Okay ! Step 2: when I do this command telnet 32.15.48.2 1521 from the server or another linux I got this error: – Grapain Gaming Dec 26 '16 at 12:33
  • from the server: telnet: connect to address 32.15.48.2: Connection refused and from another linux client: telnet: Unable to connect to remote host: No route to host Steps 3: it's OKay I put the IP adress in the listener.ora file Steps 4: Okay the databes is running – Grapain Gaming Dec 26 '16 at 12:36
  • you need to check your firewall, make sure the connection is accepted. – Ahmad Abuhasna Dec 26 '16 at 14:05
  • THANKS YOU A LOT guys, It was the firewall ^^ The port 1521 and 5500 wasn't open on my server. I open it by doing firewall-cmd --permanent --zone=public --add-port=1521/tcp – Grapain Gaming Dec 26 '16 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.