1

I have installed MS SQL Server Developer 2014. I am trying to attach the Adventure Works database. The usual process I would follow is:

1) Right click on Databases 2) Select Attatch 3) Click Add

Step four usually involves navigating the file system to find the .mdf and .ldf, however instead of a file system I see this:

enter image description here

I am a Developer and not a DBA. I am also new to SQL Server 2014.

What do I do now?

  • Outside of SQL Server when you browse the files, what are the extensions and name of the file(s)? I recall downloading adventureworks and it being a .bak file, so you restore a backup of the adventureworks which places the MDF and LDF files, not having to attach them. Also, did you verify the Adventureworks download is the same SQL Server version as yours? There are various versions. (2008 R2, 2012, 2014, etc.) – Shaulinator Dec 28 '16 at 21:07
  • @Shaulinator, I should at least see a file system when trying to browse regardless of whether the files are correct (I have checked this with 2008,2008 R2 and 2012 - I see a filesystem with each of these). – w0051977 Dec 28 '16 at 21:10
  • You should if they do exist there, yes. So the GUI is failing you and there is an issue with it. I would step back and use T-SQL. msdn.microsoft.com/en-us/library/ms190209.aspx This also gave me an idea, perhaps there's a problem with permissions somehow which is causing the issue. – Shaulinator Dec 28 '16 at 21:25
  • @w0051977 - what happens when you click the magnifying glass in the upper right hand area of your posted image? – SQL_Underworld Dec 28 '16 at 21:56
1

Just to eliminate access or permission related issue.... Check the following below: **What login is running the SQL Service - For testing, change this to localsystem or a local administrator **Are you running your SSMS with administrative privileges - If not run as administrator before connecting to your instance

Also try using other modules in SSMS that would require a browsing to a file and check if that works. For example, instead of using the attach option, test using a restore from backup. HTH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.