7

In the Oracle SQL Developer on my manjaro Linux, the blinking cursor in the editor area won't show anymore. I deleted everything of local config files (~/.sqldeveloper/) and reloads the program. At first, the cursor is visible again but after i pressed the "excute script (F5)"-Button, it will get lost and there seems no way to fix this.

My setup:

SQL Developer

Version 4.1.5.21 Build MAIN-21.78

Java

java version "1.8.0_112" Java(TM) SE Runtime Environment (build 1.8.0_112-b15) Java HotSpot(TM) 64-Bit Server VM (build 25.112-b15, mixed mode)

OS

Linux 4.4.39-1-MANJARO

closed as off-topic by mustaccio, RDFozz, McNets, Erik Darling, hot2use Sep 15 '17 at 6:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – mustaccio, RDFozz, McNets, Erik Darling, hot2use
If this question can be reworded to fit the rules in the help center, please edit the question.

3

Adding AddVMOption -Dsun.java2d.opengl=true to ~/.sqldeveloper/<version>/product.conf fixed it for me.

  • Worked with version 18.3 – Tapas Bose Jan 10 at 4:59
  • Didn't fix the issue for me unfortunately. – Malvineous Mar 29 at 1:52
1

Sometimes the cursor gets hidden because of different monitor resolutions. Try to change the font size by going to Tools > Preferences > Code Editor > Fonts.

Not the answer you're looking for? Browse other questions tagged or ask your own question.