2

I recently started receiving the following error on a dev server. At one point SQL Server 2016 CTP was installed here but we've upgraded since then. I've tried uninstalling / reinstalling SSIS as well as repairing it. Reboots occurred along the way. For the life of me I can't figure out why this error persists.

I've verified that the DTExec.exe is located where SQL Server expects it to be, using:

SELECT * FROM msdb.dbo.syssubsystems

...and that it's not referencing some other version of DTExec.exe previously installed on the server.

Is there anything else I can attempt to clear this alleged evaluation period?

Executed as user: (Domain\SQLServiceAccount).
Microsoft (R) SQL Server Execute Package Utility Version 13.0.1601.5 for 64-bit Copyright (C) 2016 Microsoft. All rights reserved.
Started: 11:00:01 PM
Error: 2017-01-03 23:00:54.81 Code: 0xC0000033 Source: XXXX ETL XXXX
Description: Integration Services evaluation period has expired.
End Error
Error: 2017-01-03 23:00:57.39 Code: 0xC0000033 Source: XXXX ETL XXXX
Description: Integration Services evaluation period has expired.
End Error
Could not execute package because of error 0xC0000033.

The rest of the instance is fine. It is only SSIS that is producing the "evaluation period expired" error message.

Maybe someone have accidentally used an Evaluation Edition to set up SSIS? Perhaps, but you'd think an uninstall and subsequent reinstall (using a dev edition install kit) of the service would correct that problem if that were the case.

1

Run regedit and change the value of CommonFiles REG_DWORD under:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\130\ConfigurationState

...from 1 to 3.

Run the Edition Upgrade and this will "upgrade" the components.

If that doesn't resolve the issue, then we need to make sure the client components are on the same service pack/build version as SQL Server. If you have applied SP1 to SQL Server, check and make sure SP1 successfully installed on the client components as well. Looking at your setup bootstrap logs will help determine that.

1

I recently removed SQL Server 2016 Trial, SQL Server 2012, and a corrupted version of SQL Server 2008 from a 2012 VM server. Installed licensed SQL Server 2016, but once the 180 days passed from the previous trial install, Maintenance Plans stopped executing thru SSA, giving the "Evaluation Period Has Expired" message.

Found this post, looked up the registry key identified, and there were three values all set to "1". I hunted around for which one or ones to change and couldn't find anything, so I changed all of them to "3". Ran the Edition Upgrade.

On the panel where you select the instance, there's an option in the drop-down for "Upgrade Shared Components Only". Selected that and ran the upgrade. Worked perfectly. Maintenance plans running again.

  • Do you recall which 3 registry keys you changed? – SQL_Underworld Aug 3 '17 at 18:12
0

Community wiki answer:

A couple of times I have had to:

  1. Backup the databases
  2. Uninstall the SQL Server
  3. Delete everything from the folders where the SQL Server components exist
  4. Perform a new install of SQL Server and restore the databases.

The uninstaller is not always able to uninstall everything (do not know why), resulting in problems like you are facing.

-4

try using Edition Upgrade from SQL Server Installation Center

  • 1
    And what should he pick as options in that edition upgrade? Both other answers already mention the tool so I'm not sure what this answer is adding. – Tom V Sep 5 '17 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.