3

I am attempting to upgrade MS SQL Server 2012 (sp3) to SQL Server 2014.

At the end of the upgrade several components fail with an error that says,

"Error details: Error installing SQL Server Database Engine Services Instance Features Failed to create a new folder 'H:\MSSQL11_MSSQLSERVER_Backup_Dir'. The specified path is invalid (for example, it is on an unmapped drive). Error code: 0x84CF000E"

This server does not have an H:\ drive. As far as I know, it never did have an H drive. How can I correct this?

migrated from stackoverflow.com Jan 6 '17 at 19:29

This question came from our site for professional and enthusiast programmers.

5

Run this

EXEC master.dbo.xp_instance_regread
N'HKEY_LOCAL_MACHINE', N'Software\Microsoft\MSSQLServer\MSSQLServer',N'BackupDirectory'

to see what your default backup directory is set to.

This can also be viewed in Management Studio by right clicking on your instance, selecting Properties and going to the Database Settings tab. It will be near the bottom under Database default locations. If your default backup directory is set to 'H:\MSSQL11_MSSQLSERVER_Backup_Dir', changing it will help.

  • Good call. Sounds like a network attached drive for backup. – Laughing Vergil Jan 6 '17 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy