-1

When I try to connect to the database, to which I was previously able to connect, I get the following error:

enter image description here

I tried to solve this by looking up other stackoverflow questions and online resources, but without success. Any help is appreciated.

  • Version mismatch. – SQL_Underworld Jan 7 '17 at 15:52
  • What troubleshooting have you done so far? – mustaccio Jan 7 '17 at 18:11
  • Thank you everyone for the comments, I updated to Visual Studio 2015 Update 3 through Tools -> Extensions and Updates and it fixed the problem and now the versions match – Dimitar Nikovski Jan 8 '17 at 18:10
0

Version 852 is SQL Server 2016 - Your LocalDB is version 851 for VS2015

  • You try change compatibility level(lower)

    ALTER DATABASE DatabaseName SET COMPATIBILITY_LEVEL = 120;
    GO

Compatibility level 120 is SQL Server 2014 - version is 782.

I hope that It will work.

  • Thank you, this is a solution as you have answered. However, I did it via updating Visual Studio 2015 to the latest Update 3 and it fixed the issue. – Dimitar Nikovski Jan 8 '17 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.