I installed MariaDB_Galera_server10.0 , but when i check the error log i see this:

170118 14:49:09 [Note] InnoDB: 128 rollback segment(s) are active.
170118 14:49:09 [Note] InnoDB: Waiting for purge to start
170118 14:49:09 [Note] InnoDB: Percona XtraDB (http://www.percona.com)    5.6.34-79.1 sta
rted; log sequence number 1627308
170118 14:49:09 [Note] Plugin ‘FEEDBACK’ is disabled.
170118 14:49:09 [Note] WSREP: Service disconnected.
170118 14:49:10 [Note] WSREP: Some threads may fail to exit.
170118 14:49:10 [Note] InnoDB: FTS optimize thread exiting.
170118 14:49:10 [Note] InnoDB: Starting shutdown...
170118 14:49:10 [Note] InnoDB: Waiting for page_cleaner to finish flushing   of buffer po
170118 14:49:11 [Note] InnoDB: Shutdown completed; log sequence number   1627318

this is the cluster configuration '/etc/mysql/conf.d/cluster.cnf' :



wsrep_sst_method= rsync
wsrep_sst_auth = wsrep_sst_user:wsrep_sst_pass

and my.cnf :

# MariaDB database server configuration file.
# You can copy this file to one of:
- “/etc/mysql/my.cnf’ to set global options,
# - “—/.my.cnf” to set user-specific options.
# One can use all, long options that the program supports.
# Run program with - -help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
# For explanations see
# http://dev .mysql .com/doc/mysql/en/server-system-variables.html
# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain “#‘ chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.


port = 3306
socket = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# This was formally known as [safe_mysqid] . Both versions are currently parsed.

#1og-error= /var/log/mysqld.error.log
socket = /var/run/mysqld/mysqld.sock
nice =0

#* Basic Settings
user = mysql
pid - file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/1ib/mysql
tmpdir = ltmp
lc_messages_dir = /usr/share/mysql
lc_messages = en_US

# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
#bind-address =
#* Fine Tuning
max_connections = 100
connect_timeout = 5
wait_timeout = 600
max-allowed_packet = 16M
thread_cache_size = 128
sort_buffer_size = 4M
bulk_insert_buffer_size = 16M
tmp_table_size = 32M
max_heap_table_size = 32M
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched. On error, make copy and try a repair.
myisam_recover_options = BACKUP

key_buffer_size = 128M
#open-files-limit = 2000
table_open_cache = 400
myisam_sort_buffer_size = 512M
concurrent_insert = 2
read buffer size = 2M
read md buffer size = 1M
#* Query Cache Configuration
# Cache only tiny result sets, so we can fit more in the query cache.
query_cache_limit = 128K

# for more write intensive setups, set to DEMAND or OFF
#query_cache_type = DEMAND
* Logging and Replication
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime’
general_log_file = /var/log/mysqi/mysql.log
general_log = 1
# Error logging goes to syslog due to /etc/mysql/conf.d/mysqld_safe_syslog.cnf.
#1og-bin=/var/log/mysql-bin .log
#]og-error= /var/log/mysqld.error.iog
# we do want to know about network errors and such
]og_warnings = 2
# Enable the slow query log to see queries with especially long duration
#slow_query_log[={O 1})
slow_query_log_file = /var/log/mysql/mariadb-slow.log
long_query_time = 10

log_slow_verbosity = query_plan
#log -queries -not -using -indexes
The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication sl.ave, see README.Debian about
other settings you may need to change.
server-id = 121
#report_host = masterl
#auto_inc rement_inc rement = 2
#auto_increment_offset = 1
log_bin = /var/log/mysql/mariadb-bin
log_bin_index = /var/log/mysql/ma riadb-bin.index
# not fab for performance, but safer
#sync_binlog = 1
expire_logs_days = 10
max_binlog_size = lOOM
# slaves
relay_log = /var/log/mysql/relay-bin
relay_log_index = /var/log/mysql/relay-bin.index
relay_log_info_file = /var/log/mysql/relay-bin.info

# If applications support it, this stricter sql_mode prevents some
# mistakes like inserting invalid dates etc.
* InnoDB
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/
# Read the manual for more InnoDB related options. There are many!
default_storage_engine = InnoDB
# you can’t just change log file size, requires special procedure
nnodb_log_file_size = SOM
innodb_buffer_pool_size = 256M
innodb_log_buffer_size = 8M
innodb_file_per_table = 1
innodb_open_files = 400
innodb_io_capacity = 400
innodb flush method = 0_DIRECT

#* Security Features
# Read the manu&L, too, if you want chroot!
# chroot = /var/lJb/mysql/
# For generating SSL certificates I recommend the OpenSSL GUI “tinyca”.
# ssl. -ca=/etc/mysql/cace rt . pem
# ssl-cert=/etc/mysql/server-cert .pem
# ssl -key=/etc/mysql/server-key .pem

#*Galera-related settings

#Mandatory settings

log -bin=/var/log/mysql/mysql-replication.og
# Allow server to accept connections on all interfaces.
# Optional setting
max_allowed_packet = 16M
#no-auto-rehash # faster start of mysq1. but no tab completion

key_buffer = 16M

*# IMPORTANT: Additional settings that can override those from this file!
# The files must end with ‘.cnf’, otherwise they’ll be ignored.

!includedir /etc/mysql/conf.d/
  • Please add the command you used to start Galera to the question. Also, you might move the wsrep_slave_threads=16 setting to the galera config file just to keep them all in the same place. Commented Jan 19, 2017 at 15:09
  • service mysql start --wsrep-new-cluster
    – Yaser Jawi
    Commented Jan 20, 2017 at 7:54

1 Answer 1


Maybe some of these typos are causing it to croak:

#]og-error= /var/log/mysqld.error.iog
# we do want to know about network errors and such
]og_warnings = 2
# Enable the slow query log to see queries with especially long duration
#slow_query_log[={O 1})
nnodb_log_file_size = SOM
log -bin=/var/log/mysql/mysql-replication.og

(There may be more!)

Unless you have a tiny amount of RAM, this should be more like 70% of RAM:

innodb_buffer_pool_size = 256M
  • these typos caused because of bad copying way (from the terminal to here) they r not as in real..
    – Yaser Jawi
    Commented Jan 20, 2017 at 7:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.