6

I want set up replication between an Amazon RDS MySQL DB instance and a MySQL instance that is external to Amazon RDS.

but Slave_IO_Running: Connecting how to solve this problem?

I have already done the following commands.

mysql>CALL mysql.rds_set_external_master ('192.168.xx.xxx', 3306,
    'repl2', '111111', 'mysql-bin-changelog.000003', 598, 0); 

mysql> CALL mysql.rds_start_replication; 

+-------------------------+
| Message                 |
+-------------------------+
| Slave running normally. |
+-------------------------+
1 row in set (1.01 sec)

enter image description here

  • Why do you mask 192.168.xx.xxx ? – akuzminsky Jan 22 '17 at 9:30
  • I don't get it. What are you trying to achieve exactly ? Do you have a replication already in use ? From where to where ? Who will be the master ? – DeadEye Jan 22 '17 at 19:53
1

The easy way to disable replication is to run this on the RDS slave

CALL mysql.rds_stop_replication;
CALL mysql.rds_reset_external_master;

If Slave_IO_Running is Connecting, then there is one or both of the issues

  • The grants for the repl2 user is wrong
  • firewall issue on port 3306.

If the issue is the grants, drop the repl2 and add it back with

DROP USER 'repl2'@'%';
CREATE USER 'repl2'@'%' IDENTIFIED BY '111111';
GRANT REPLICATION SLAVE,REPLICATION CLIENT ON *.* TO 'repl2'@'%';

I'll leave the FW/SecurityGroup stuff to you.

Once these are cleared up, run the CALL mysql.rds_set_external_master with the proper private IP. Please don't use 192.168.x.x.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.