1

I have installed SQL Server 2014 Express Edition ( 12.0.2000.8 x64 ) on a Windows server 2012 machine.

Because of the POODLE vulnerability, our IT department is going to disable TLS 1.0 and all other previous security protocols on this server.

Where can I find a newer version of SQL server Express Edition that can support OR work with TLS 1.2?

2

You don't strictly need a newer version of SQL Server; however as a general thing I always prefer to be using the most recent version (especially in this case, because in SQL Server 2016 SP1, you get all kinds of new features in Express Edition).

You do need to apply one of the following updates, though (I go through more details in this blog post). They are listed in my order of preference:

That's the gist of it; if you want to get into all the nitty gritty, here is a KB article I'm stealing from Max's deleted post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.