I have a regular Oracle 12c database already created, named ECLS. I've been given a pile of .BKP files, not from this database, and have been told to replace everything in ECLS with the contents of these files.

With the files, I was also told to use this command to do it:

RMAN> duplicate database to ECLS backup location '/u01/dumpfilesgohere';

No other directions were provided.

I found that my database needs to be an auxiliary with nothing mounted. So I did the following:

$ sqlplus / as sysdba
SQL> shutdown immediate;
SQL> startup nomount;
SQL> exit
$ rman auxiliary /
RMAN> duplicate database to ECLS backup location '/u01/dumpfilesgohere';

This looks like it's working properly for the first few seconds... it says that it's able to restore the control files from the BKP files. But then it ends up failing. Here's the last few lines before the failure:

contents of Memory Script:
   sql clone "alter system set  db_name =
 ''ECLS'' comment=
 ''Reset to original value by RMAN'' scope=spfile";
   sql clone "alter system reset  db_unique_name scope=spfile";
   shutdown clone immediate;
executing Memory Script

sql statement: alter system set  db_name =  ''ECLS'' comment= ''Reset to original value by RMAN'' scope=spfile

sql statement: alter system reset  db_unique_name scope=spfile

Oracle instance shut down
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of Duplicate Db command at 01/30/2017 14:59:06
RMAN-05501: aborting duplication of target database
RMAN-03015: error occurred in stored script Memory Script
RMAN-06136: ORACLE error from auxiliary database: ORA-65093: multitenant container database not set up properly

What am I doing wrong? What files do I need to change to get this error message to stop occurring?

Alternatively... if my whole database install isn't going to work, can someone tell me what I need to do differently when reinstalling the database?

1 Answer 1


65093, 00000, "multitenant container database not set up properly"

Cause: An attempt was made to open a multitenant container database without the correct parameter set for a multitenant container database in the initialization parameter file.

Action: Set the 'enable_pluggable_database=true' parameter for the multitenant container database in the initialization parameter file and restart the database.

By default ENABLE_PLUGGABLE_DATABASE is set to FALSE. We need to set this parameter to TRUE before creating CDB.

RAMN>duplicate database to ECLS
    set enable_pluggable_database=true
 backup location '/u01/dumpfilesgohere';
  • 1
    I needed to put true in single quotes for it to accept it. Now it's giving me this error message: DUPLICATE without TARGET connection when auxiliary instance is started with spfile cannot use SPFILE clause. Jan 31, 2017 at 17:30
  • 1
    Place this parameter in pfile(probably initECLS.ora file) in your database and restart it with pfile in nomount mode.
    – atokpas
    Jan 31, 2017 at 23:45
  • This line is already present in initECLS.ora: *.enable_pluggable_database=true, and as I showed in my question, I am starting up the database using startup nomount in sqlplus. Feb 1, 2017 at 14:47
  • 1
    It uses spfile, if present, by default while starting up the instance. So either you have to rename the spfile to some other name or have to specify init.ora file explicitly as SQL> startup pfile='/path/to/pfile.ora' nomount
    – atokpas
    Feb 1, 2017 at 15:04
  • Thanks for that! I've gotten further along now. Now I'm getting this error message: RMAN-05001: auxiliary file name F:\ORADATA\[...]\DATAFILE\O1_MF_OEM_TEST_D14SM11V_.DBF conflicts with a file used by the target database. It repeats that message 67 times, and says its aborting duplication. If you know the solution, I'd love to hear it. I'll try to research it a bit and ask another question here if I find nothing. Feb 1, 2017 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.