2

We have an SSRS 2014 already in production and we want now use a secure site by linking it to a certificate (URL like "https://..."). So now the URL is fully qualified domain name(FQDN).

We can access correctly to the report manager with this https URL. We have to register to access with the Windows account.

The bug we have is that when we navigate, sometimes, we pass to an http page. Each time that we pass from an https to an http page, the browser (IE) ask to register again.

For example, here we are on a https page. When I click right on a report -> manage: enter image description here

I arrive on this page: enter image description here

If I clic on a tab on the left pane (for example in Security), SSRS ask me to reconnect and jump to an http page. This is a real problem for us.

Any suggestions?

  • As far as I know, this is a bug that is fixed in 2016--I'm not sure if Microsoft has (or could/would) fix it in a service pack for 2014. – AMtwo Feb 2 '17 at 16:10
2

Well, it was difficult to solve, but with the help of our sysadmin and reading through lot of places, we managed to get it working. It was a mix of things, but the 2 main ones were changing some parameters on SSRS config file:

  1. Change <Add Key="SecureConnectionLevel" Value="0"/> to <Add Key="SecureConnectionLevel" Value="3"/>
  2. Make sure that <RSWindowsNTLM/> is the only authentication type specified on <AuthenticationTypes>
  3. make sure all url's are absolute, without wildcards

And second part was to modify a windows registry and restart SSRS afterwards:

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

Create a new DWORD registry key DisableLoopbackCheck and set value to 1.

In case you are wondering, here are all the references consulted:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.