3

For some reason SQL Server 2012 keeps hanging at SqlRsConfigAction_install_ConfigNonRC_Cpu64

There isn't any Windows installer running apart from the SQL Server setup.

Update on Resolution Install SQL2012 without selecting Reporting Services

  • Are you sure you've killed any other installer background processes, not just checked that there's no other installer running in the foreground? – T.H. Feb 9 '17 at 10:47
  • Windows installer is not running in services.msc. In the foreground, there's no other setup running apart from SQL – deepz Feb 9 '17 at 10:51
  • I don't think services.msc can help here. You need to check all processes in task manager ("processes" tab in the style of Windows 7 and earlier, "details" tab in the style of Windows 10 and likely 8 as well). You may want to check for details of what processes to kill in other posts where people have solved this sort of problem. – T.H. Feb 9 '17 at 11:23
  • Can you add contents of Errorlog file generated after failed installation in the question – Shanky Feb 9 '17 at 11:48
  • @Shanky please see the logs – deepz Feb 9 '17 at 13:50
0

Solved this problem after uninstalling Microsoft Visual C++ 2017 Redistributable (x86) and (x64) and reinstall successfully sql express 2016.

But the best solution for avoiding this issue is install sql server management studio and sql server express before installing visual studio

  • 1
    Question is about SQL Server 2012. – McNets Feb 4 '18 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.