Following the link Link I tried to verify ssas backup and executed below mentioned command in specified path as in link.

msmdsrv -j -b "\\path\ssasfile.abf"

But all it outputs is the arguments I passed in:

 -j -b \\path\ssasfile.abf

However, I was expecting output as mentioned in the post How to check the health of a SSAS database? And of its backups?. Any suggestion is much appreciated.

1 Answer 1


That's what happens when you pass in a backup file that either doesn't exist or on which you don't have access.

For example if I run the command on an existing backup file I get this:

msmdsrv -j -b "c:\temp\AdventureWorksDW2012Multidimensional-EE.abf"

Outputs the arguments as well as the test results:

-j -b c:\temp\AdventureWorksDW2012Multidimensional-EE.abf

Backup file \?\c:\temp\AdventureWorksDW2012Multidimensional-EE.abf contains database with the Name of AdventureWorksDW2012Multidimensional-EE and Id of AdventureWorksDW2012Multidimensional-EE consisting of 7927 files with the total size of 5554858464 bytes All files were successfully tested

You can see the output starts with the arguments and then shows the test results.

If you point msmdsrv.exe to a non existing backup file it just returns the arguments and no results (unfortunately no error message either)

msmdsrv -j -b "c:\temp\NOTEXISTING.abf"

simply returns

-j -b c:\temp\NOTEXISTING.abf

  • \\path\ssasfile.abf was just an example. I am sure i am passing existing backupfile and has access to the path Feb 14, 2017 at 9:32
  • 1
    @PramodMaharjan I'm not sure if it's your account that needs access or the service account for Analysis services
    – Tom V
    Feb 14, 2017 at 9:55
  • Provided access to network service as well but couldn't make it work. Thanks for the effort. Feb 14, 2017 at 11:19
  • @PramodMaharjan what account had network share access? The SSAS Service account of your account? Feb 15, 2017 at 4:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.