4

I'm getting an error message whenever I double click on a Notify Operator Task in our Maintenance Plans in SSMS, which says "Cannot show the editor for this task."

Property IsMailHost is not available for Database '[msdb]'. This property may not exist for this object, or may not be retrievable due to insufficient access rights. (Microsoft.SqlServer.Smo)

Database mail is configured and working OK.

I'm using SQL Server 2016 (13.0.4411.0) and SSMS 13.0.16106.4.

Interrogating the IsMailHost property via PowerShell seems to indicate that the IsMailHost property is true.

$db = SqlServer\Get-SqlDatabase -ServerInstance sqlserver1 -Name msdb
Write-Host $db.IsMailHost

The above script returns True.

If I try to open a Notify Operator Task on our old SQL 2008 server, with SSMS 10.0.5538.0, it works fine, but with SSMS 13.0.44110.0, I get the same error message. I'm beginning to think it's a fault with this build of SSMS rather than a configuration issue with the server.

migrated from serverfault.com Feb 20 '17 at 21:30

This question came from our site for system and network administrators.

  • Make sure you have .NET 3.5 installed - support.microsoft.com/en-us/help/3186435/… – Scott Hodgin Feb 20 '17 at 21:44
  • I've got .NET 3.5 installed on both the server and the client... and the issue presents itself when running SSMS on the server and on two clients... all of which are Windows Server 2012 R2 and Windows 8.1. I tried SSMS vNext, but it comes up with the same error message. – Matty Brown Feb 20 '17 at 22:18
  • Any chance PowerShell is running in admin mode and you didn't click "run as administrator" on ssms? Maybe it's UAC kicking in. – Tom V Feb 22 '17 at 12:56
  • Both say (Administrator) in the title bar. We've actually disabled UAC via Group Policy... I wonder if that could have any bearing on it? – Matty Brown Feb 22 '17 at 22:26
  • Do you have the Database Mail configured? and are the Profiles created working fine? If Yes, have you created Operator to whom you want to send mail?. Notify Operator works only if operator is created with valid Email ID. – MarmiK Nov 15 '18 at 16:27
0

According to this SSMS on Microsoft Docs

Build number 14.0.17099.0 will likely fix your issue.

Fixed an issue where "Maintenance Plans Tasks Toolbox" items may be missing in SSMS.

Not the answer you're looking for? Browse other questions tagged or ask your own question.