1

I have tried upgrading in-place to Mysql 5.7.x from 5.6.33 as well as directly from 5.5.46 on Ubuntu 14.04.5 LTS, but I keep getting stuck at the same step.

I followed this answer successfully to upgrade from 5.5.46 -> 5.6.33 in-place: https://askubuntu.com/a/750502/482945 but I could not get it to work for 5.5.46 -> 5.7.x .

After installing mysql-apt-config:
$ sudo dpkg -i mysql-apt-config_0.8.0-1_all.deb

I tried this several times:
$ sudo dpkg-reconfigure mysql-apt-config

Each time on the displayed menu (see https://askubuntu.com/a/750502/482945) I selected the 5.7 option followed by:
$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install mysql-server-5.7

But I get the same message:

Package mysql-server-5.7 is a virtual package provided by:
percona-xtradb-cluster-server-5.7 5.7.16-27.19-1.trusty
percona-server-server-5.7 5.7.17-11-1.trusty
You should explicitly select one to install.

Package 'mysql-server-5.7' has no installation candidate

I verified that the repo actually contains a 5.7 binary: http://repo.mysql.com/apt/ubuntu/dists/trusty/mysql-5.7/binary-amd64/Packages

$ apt-cache search mysql-server-5.7
also does not show mysql-server-5.7

$ sudo apt-get update hits 5.7 urls, but does not fetch the packages.

In one attempt mysql-common was "held back" by apt and probably that was causing the absence of 5.7 but I ran apt-get upgrade and removed mysql completely, but still no use.

As mentioned above, I've tried 5.5 -> 5.7 as well as 5.5 -> 5.6 -> 5.7 but I simply do not get the package to install.

This blocks my attempt to run an in-place upgrade test.
A logical upgrade will need significant downtime which I cannot afford.

Any help is greatly appreciated !

PS: There are other unrelated "gpg key expired" errors because MySQL Release Team's GPG keys(1487236823) and/or Percona's APT keys(8507EFA5) have expired or changed - these errors are easily fixed with some googling.

  • why don't you install just percona-server-server-5.7 . like: apt-get install percona-server-server-5.7 – bwk Feb 21 '17 at 21:46
  • it mean in Your repository You have mysql 5.7 from Percona. If You want install MySQL from Oracle You need first purge Percona from repository, than repeat steps, or just install Percona version – a_vlad Feb 22 '17 at 1:16
  • @bwk I considered that, but percona support is on forums (slow) or paid (expensive for me). Does everything on 5.6 / 5.7 work exactly as stock MySQL does? Because if there are hidden bugs, I don't know if Google will provide as many answers as for stock mysql. – site80443 Feb 23 '17 at 12:26
  • @a_vlad I need Percona repository for Percona Toolkit and Xtrabackup. Would altering priorities of the repos help ... like so: askubuntu.com/questions/293619/assign-higher-priority-to-ppa – site80443 Feb 23 '17 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.