1

I attempted the following:

mysqldump -u root -p sa -n -d -t --routines --skip-triggers --all-databases > C:\backups\MySQLStoredProc.sql

but only received back;

Usage: mysqldump [OPTIONS] database [tables]  
   OR  mysqldump [OPTIONS] --databases [OPTIONS] DB1 [DB2 DB3...]  
   OR  mysqldump [OPTIONS] --all-databases [OPTIONS] 
   For more options, use mysqldump --help

I see no problem with my command. Does anyone see a problem with it? The results of mysqldump --version is

mysqldump  Ver 10.13 Distrib 5.7.9, for Win32 (AMD64)
  • space between -p and 'sa' is causing your problem, presumably 'sa' is not your password and is some options? – slowko Mar 3 '17 at 15:59
  • yes, that was the problem. I removed the space. sa is the password. – cupboy Mar 5 '17 at 4:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.