1

I have been given the task of setting SharePoint Foundation 2010 up in work. I have hit quite a few problems (see other questions I have posted), so I decided to start from scratch again. I have installed SharePoint and SQL Server 2008. Now I'm at the step of provisioning the BLOB storage and have the following three queries to run:

use [ContentDbName]
if not exists (select * from sys.symmetric_keys where name = '##MS_DatabaseMasterKey##')create master key encryption by password = N'Admin Key Password !2#4'

use [ContentDbName]
if not exists (select groupname from sysfilegroups where groupname=N'RBSFilestreamProvider')alter database [ContentDbName] add filegroup RBSFilestreamProvider contains filestream

use [ContentDbName]
alter database [ContentDbName] add file (name = RBSFilestreamFile, filename = 'c:\Blobstore') to filegroup RBSFilestreamProvider

The first bit executes without a problem, but the second gives the message:

Msg 5591, Level 16, State 3, Line 2
FILESTREAM feature is disabled.

I have went into the Configuration Manager and checked that FILESTREAM was enabled, which it was. I restarted the service and still get the same message. Even restarting the server totally does not help.

What should I do?

Thanks! Mark

3

I would suggest double checking all the requirements for enabling FILESTREAM as per:

How to: Enable FILESTREAM

1
  • Step 11 worked for me – JSON Mar 11 '20 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.