8

Background

I am attempting to install Oracle 12c on CentOS 7 (deployed as a Hyper-V virtual machine) as outlined by this installation guide.

Problem

Everything with my installation goes well except for the Oracle Database Configuration Assistant.

The installation provides me with the following messages:

  1. ACTION: Specify a free port
  2. Action - Refer to the logs or contact Oracle Support Services.

Debuging Information and Actions Attempted

When I run a tail on the error log I get the following messages related to the installation:

INFO: ... GenericInternalPlugIn: getting configAssistantParmas.
INFO: ... GenericInternalPlugIn: checking secretArguments.
INFO: ... GenericInternalPlugIn: starting read loop.
INFO: Read: [FATAL] [DBT-06103] The port (5,500) is already in use.
INFO: [FATAL] [DBT-06103] The port (5,500) is already in use.
WARNING: Skipping line: [FATAL] [DBT-06103] The port (5,500) is already in use.
INFO: Read:    ACTION: Specify a free port.
INFO:    ACTION: Specify a free port.
WARNING: Skipping line:    ACTION: Specify a free port.
INFO: Completed Plugin named: Oracle Database Configuration Assistant

Running sudo netstat -anp | grep 550 returns the results below:

unix  3      [ ]         STREAM     CONNECTED     37299    5502/gnome-pty-help
unix  3      [ ]         STREAM     CONNECTED     37283    5501/gconfd-2
unix  3      [ ]         STREAM     CONNECTED     37287    5501/gconfd-2

To try and remedy the problem, prior to subsequent fresh installation attempts I commented out the following statements in my services file as displayed through running cat /etc/services | grep 550

new-rwho        550/tcp                 # new-who
new-rwho        550/udp                 # new-who
3m-image-lm     1550/tcp                # Image Storage license manager 3M Company
3m-image-lm     1550/udp                # Image Storage license manager 3M Company
ads             2550/tcp                # ADS
ads             2550/udp                # ADS
ssmpp           3550/tcp                # Secure SMPP
ssmpp           3550/udp                # Secure SMPP
gds-adppiw-db   4550/tcp                # Perman I Interbase Server
gds-adppiw-db   4550/udp                # Perman I Interbase Server
#fcp-addr-srvr1  5500/tcp                # fcp-addr-srvr1
#fcp-addr-srvr1  5500/udp                # fcp-addr-srvr1
#fcp-addr-srvr2  5501/tcp                # fcp-addr-srvr2
#fcp-addr-srvr2  5501/udp                # fcp-addr-srvr2
#fcp-srvr-inst1  5502/tcp                # fcp-srvr-inst1
#fcp-srvr-inst1  5502/udp                # fcp-srvr-inst1
#fcp-srvr-inst2  5503/tcp                # fcp-srvr-inst2
#fcp-srvr-inst2  5503/udp                # fcp-srvr-inst2
#fcp-cics-gw1    5504/tcp                # fcp-cics-gw1
#fcp-cics-gw1    5504/udp                # fcp-cics-gw1
checkoutdb      5505/tcp                # Checkout Database
checkoutdb      5505/udp                # Checkout Database
amc             5506/tcp                # Amcom Mobile Connect
amc             5506/udp                # Amcom Mobile Connect
fg-sysupdate    6550/tcp                # fg-sysupdate
fg-sysupdate    6550/udp                # fg-sysupdate
cloudsignaling  7550/udp                # Cloud Signaling Service

I have additionally attempted to do step 5.1 of the installation guide prior to the installation with no success.

Screenshot

Installation Screen with Error Messages

Question

Why am I getting an error that the port isn't open when it doesn't seem like anything is using that port and how to I remedy this issue?

Is there are method that can be used to change the port from 5500 to a complete different one? I'm just trying to get a dummy database installed for the HR schema.

13

I encountered this exact error and found it was my mistake. Spent whole day for that.

Please, carefully observe your /etc/hostname and /etc/hosts. In my case, "oem" was put in /etc/hosts and "eom" was in /etc/hostname.

| improve this answer | |
  • 5
    I neglected specifying the host in the format 192.168.1.X host host.domain. Adding the unqualified hostname fixed my problem. Thanks! – datUser Nov 16 '17 at 16:13
  • Yes, adding the unqualified hostname to /etc/hosts fixed my problem in RHEL 6.10. – tale852150 Dec 6 '18 at 21:24
  • I had the same problem. Adding the hostname into the /etc/hosts fixed this issue. See support.oracle.com/knowledge/Oracle%20Database%20Products/… for further information. – Roman Vogt May 6 at 15:24
7

You might want to try adding your host to /etc/hosts.

I encountered the same error and the problem went away after I've done so.

See Install Oracle Database 12c On CentOS7 by M.el Khamlichi.

Example from that link:

192.168.119.139 ora-c7.unixmen.local
| improve this answer | |
  • Adding the host to /etc/hosts didn't work. – Dodzi Dzakuma Apr 12 '17 at 15:04
1

Community Wiki answer created from a comment left on the question:

You can change the port for EM Express with DBMS_XDB_CONFIG.SETHTTPPORT and DBMS_XDB_CONFIG.SETHTTPSPORT. But EM Express is optional, you can just simply skip it. - Balazs Papp

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.