2

After one of our servers had been up fine for a couple of months, we started receiving a vague network error for small time windows in the late hours of the night, when some jobs were running. It would only appear to happen for 30 minutes or so at a time, then the same jobs would work fine.

Today, the issue occurred during business hours, but I was unable to find anything that stood out as an issue (server was not under a great deal of load, and there were no open transactions).

The error message was:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections.

I found that I was able to resolve the issue by disabling and re-enabling the internal NIC. Given we hadn't had a restart for a few months and the windows updates were piling up, I updated and restarted.

From the server itself, management studio was unable to connect to the server, receiving the same "Cannot Connect to Server - A network-related or instance-specific error” error. I tried uninstalling windows updates and rebooting, but this did not resolve the issue.

I also tried restarting the NIC, but this didn't work either.

I was able to resolve the issue by going into the SQL Server configuration manager, and in the TCP/IP settings I set "Listen all" to "Yes". After doing this, I was able to connect again. I've since run a netstat -a and can see the default port 1433 is listening.

Any ideas what is going on here, am I somehow running on the wrong port? Let me know if there's any more information i can provide to help?

  • This sounds like a bug in the network driver stack. – Max Vernon Mar 21 '17 at 18:13
  • Our network/security folks have been silently creating VLANS and VRFs and isolating ports causing connectivity havoc just like this. I'd make sure that nothing has changed on your network. I walked in one day not being able to RDP to my Azure server because they decided to block port 3389. I've also had spurious SQL Server connectivity issues just like yours. I really hope it is a driver/stack issue--that's a lot easier to pinpoint. – Sting May 8 '18 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.