0

Because my memory seemed to be rapidly disappearing (according to the Task Manager graph), but I couldn't see any programs using it, I downloaded RAMMap to get a better picture of what's going on. Turns out all of my memory was being chewed up by AWE.

When I try to research this, however, everyone seems to say that AWE isn't enabled for SQL Server 2012 64 bit systems, since it isn't needed; the expanded memory that AWE would enable is directly accessible. But the system still will happily chew up memory in AWE until it reaches its limit.

How can I disable this and free the 24GB ram?

1

I would recommend you to read this article: https://blogs.msdn.microsoft.com/psssql/2009/09/11/fun-with-locked-pages-awe-task-manager-and-the-working-set/

It covers all possible questions about AWE and answers to them Also you might find the post from Paul Randal helpful: A SQL Server DBA myth a day: (5/30) AWE must be enabled on 64-bit servers

0

Once sql consumes the memory, you can't give it back, unless you have dynamic memory management set up, and you recycle the sql service to free it up. What you can do though is limit the amount of memory that can be consumed by sql server by setting the max server memory to some value, thus limiting what it can use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.