I'm deploying SQL Server 2008 Express in my company. I already installed, did a application, tested, gave permission to user.

All desktop users run the program without any problem. But the notebook users can't establish a connection with SQL Server.


  • Notebook has permission in the company's network (already access network drive)
  • Notebook pings the computer with SQL Server.
  • I gave permission for the company's groups and explicit for notebook users
  • Firewall and Anti-virus is turned off in SQL Server computer.

Any idea?

System.Data.SqlClient.SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

EDIT: The problem was that the notebooks wasn't in the same domain.

  • Have you made any progress in getting the laptops to communicate with the SQL servers? I'd be interested in knowing what the resolution was. – mdoyle Apr 26 '12 at 14:52
  • Sorry. I'm doing it now. – Makah May 7 '12 at 13:53

This sounds like a network problem; if the other remote clients can access the instance then it seems unlikely it is an instance-specific problem.

  1. Be sure that firewalls on the notebooks are turned off or (better) are allowing TCP traffic through the port your server is using.
  2. If you are connecting using the server's host name or machine name, make sure it resolves to the correct IP from the notebooks. Try this from a command prompt on the notebooks:

    C:\> ping my.databaseserver.com


    C:\> ping OUR_SQLSERVER 

    In the output the IP address to which my.databaseserver.com/OUR_SQLSERVER resolves will be displayed.

  3. See if you can connect directly via TCP to check for misconfiguration of the SQL clients. On the notebooks, type this at a command prompt:

    C:\> telnet 1433

Substitute your SQL Server's IP and the port it is using. The reply you get will not be readable, but unless you get a message like Could not open connection to the host, on port 1433: Connect failed, you are at least able to connect to the server.

Hope this points you toward a resolution.

  • I agree that it sounds like a network problem. Are the desktop users and notebook users running on the same physical network? It might be that the wired network and wifi network have different firewalls in place, enforced by hardware firewalls and not just software on the computer. – darin strait Apr 24 '12 at 11:24
  • i tried to telnet and got an error. i verify the port in Configuration Manager and got the default 1433. I tried to telnet in the server and i got the same problem. :/ – Makah May 7 '12 at 18:46
  • Notebooks are not in the same domain but the they are in the same DNS. – Makah May 7 '12 at 19:01
  • What error did you get when trying to telnet? – mdoyle May 7 '12 at 20:26
  • unable to open host in port 1433. – Makah May 7 '12 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.