1

I am new to MySQL and AWS. I have set up a new (free trial) AWS account for the purpose of setting up a MySQL database server that I can access from multiple PCs.

Per the AWS RDS tutorial, I set up a PVC, 2 Subnets (one public, one private), an Internet Gateway, a Security Group, then created a DB instance with MySQL. At the end of the process I successfully created MySQL RDS instance, however I get the following error when I look at its details.

"Endpoint Mysqlinstanace.xxxxxxxxxxx.us-west-2.rds.amazonaws.com:3306 ( No Inbound Permissions )"

I have read many places where you need an Inbound Rule to allow access. My Security Group has the following Inbound Rule. Type HTTP Protcol TCP Port Range 80 Source 0.0.0.0/0

My understanding is the Source 0.0.0.0/0 is not good security as it allows anyone to access the DB. That is ok for now as I am just trying to see if I can make a connection from my desktop.

Does anyone have an idea as to how to open up the DB Instance for access from my desktop? I am using MySQL Workbench to make the connection.

Thank you

  • I was able to get rid of the 'No Inbound Permissions' error in RDS by changing the Inbound Rule to TYPE = 'MYSQL/Aurora' which then set the Port Range to 3360. RDS now shows green 'authorized'. However, when I try to connect to it from MySQL Workbench, I get a error - 'Cannot connect to database server .... (10060) – Andrew Apr 4 '17 at 20:29
  • I created an RDS Mysql instance with the default settings without creating any Security Group or other stuff. Everything shows up as green with public access enabled. But when I try to access it from my PC, I can't. I get the same 10060 error. I tried tracert to the endpoint but the trace ends at amazon-ic-302506-sea-b1.c.telia.net [213.248.84.190]. Anyone, any idea? – blokeish May 16 '17 at 5:48
0

I think your problem is here "Type HTTP Protocol TCP Port Range 80 Source 0.0.0.0/0". Mysql uses port 3306 by default which you have not enabled. For testing you can allow all ports and all protocols and later refine it.

My problem stated above was slightly different. I was able to get around this by editing the inbound source, from the name (sg-xxxxx) of the security group (default) to '0.0.0.0/0' . Going to "VPC > Security Group" and select the security group that you are using for your RDS. Then edit the inbound rules.

  • I stepped away from the problem for a couple of weeks then came back to it. AWS has a new process and tutorial on how to establish the MySQL connection. It worked perfectly. I do not know what changed, but problem went away – Andrew May 24 '17 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.