0

When I restored a database backup file, which uses FILESTREAM feature, everything was fine but after a while the database went to the (recovery pending) mode. I tried restarting SQL Server service and it still didn't work. I decided to delete the database and restore it again but I got this error while restoring:

Restore of database 'Ka4' failed. (Microsoft.SqlServer.Management.RelationalEngineTasks)

System.Data.SqlClient.SqlError: FILESTREAM feature is disabled. (Microsoft.SqlServer.SmoExtended)

I've reinstalled SQL Server instance but nothing has changed and it still keeps saying the same error.

According to this page I'm sure that FILESTREAM feature is enabled.

P.S. This is my SQL Server version:

Microsoft SQL Server 2016 (RTM) - 13.0.1601.5 (X64) Apr 29 2016 23:23:58

1

Thanks to @Nic. It seems that there's a bug with Windows 10 Creators Update. After reading this article I could manage to solve the problem by changing the service startup account to built-in account LocalSystem and now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.