1

I'm experiencing a strange behavior when trying to perform a silent database creation with 12.1 DBCA.

My command:

dbca -silent -createDatabase -templateName pbw4.dbt -responseFile NO_VALUE -gdbname pbwdup -sid pbwdup -emConfiguration NONE -totalMemory 2048

After running this command, I get a prompt asking me for the SYS password, as expected. However, I'm unable to actually enter in the password because my command prompt continuously rolls back, it looks like it is just automatically deleting every text on my screen. I have to ctl+c out of it to regain control.

Below is an attempt to illustrate the behavior:

1

2

Does anyone have any idea why this is happening?

2

Bug 21163674 : DBCA SILENT MODE DELETES LINES FROM SCREEN AND DISPLAYS NO PROMPT

This happens when XTERM is run with both "Enable Reverse Wraparound" & "Enable Auto Wraparound" enabled. As soon as one of these is disabled, then dbca functions correctly.

...

With putty , settings -> terminal, uncheck 'Auto wrap mode initially on'.

Another workaround is to use silent installation with a response file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.