0

I configured an availability group in Azure using this guide. I have 2 failover cluster nodes with SQL Server 2016. User 'Install' has administrative permissions on both machines and sql server instances. I used this guide to create an avilability group listener but I failed on the final step. According to the guide I had to log in to primary replica machine as 'Install' user and create IP resource for availability group and then execute configuration script. Configuration script is

Get-ClusterResource $IPResourceName | Set-ClusterParameter -Multiple @{"Address"="$CloudServiceIP";"ProbePort"="59999";"SubnetMask"="255.255.255.255";"Network"="$ClusterNetworkName";"OverrideAddressMatch"=1;"EnableDhcp"=0}

But this script always fails with error:

Set-ClusterParameter : Parameter 'OverrideAddressMatch' does not exist on the cluster object 'Resource1'. If you are trying to update an existing parameter, please make sure the parameter name is specified correctly. You can check for the current parameters by passing the .NET object received from the appropriate Get-Cluster* cmdlet to “| Get-ClusterParameter”. If you are trying to update a common property on the cluster object, you should set the property directly on the .NET object received by the appropriate Get-Cluster* cmdlet. You can check for the current common properties by passing the .NET object received from the appropriate Get-Cluster cmdlet to "| fl ". If you are trying to create a new unknown parameter, please use -Create with this Set-ClusterParameter cmdlet.

What should I do to get rid of this error? It seems like permission issue.

  • If you run Get-ClusterParameter for that cluster resource what do you get? – Nic May 4 '17 at 15:42
  • Sounds like $IPResource isn't really an IP address resource... – Sean Gallardy May 4 '17 at 19:32
  • @SeanGallardy, it is just a placeholder parameter. I'm using the real values in my testing environment. – Vlad Ushakov May 5 '17 at 8:33
  • @Nic I've tried Get-ClusterParameter and got such error Get-ClusterParameter : The private property 'OverrideAddressMatch' does not exist. – Vlad Ushakov May 5 '17 at 13:59
0

I have to reiterate that you're not doing this on a valid IP Address resource. I have no problem getting these values from any of my clustered IP resources. Tried on Windows Server 2012R2 and Windows Server 2016, both show values just fine.

Double check your input is a valid IP Address resource type and double check it holds a resource that exists in the current context.

Windows Server 2012R2 enter image description here Windows Server 2016 enter image description here

  • Thank you! It solved my problem. I used incorrect name for IP Resource. – Vlad Ushakov May 10 '17 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.