14

I am using Windows 10, language Serbian, SQL Management Studio 2016 and can't use Database reports because there is error:

An error occurred during local report processing Culture is not supported Parameter name: culture 3072 (0x0c00) is invalid culture identifier.

I try with different settings for Windows 10 - language (English), try with different settings for SSMS (English) but got same error.

Do you have idea how to solve this?

P.S. My Windows 10 system locale settings:

Get-WinSystemLocale
LCID       Name            DisplayName
----       ----            ----
9242       sr-Latin-RS     Serbian(Latin, Serbia)

3 Answers 3

6

I think 3072 (0x0c00) is an invalid locale ID, at least according to this. So this looks like a corrupted Windows installation, perhaps from a flaky disk (eg. a byte overwrite of a locale 0x0c1a, which is the code for "Serbia and Montenegro (Former)").

You can try changing the current locale from Control Panel.

1
  • Today there was automatic big windows update on my computer and problem was solved! Thank you @RemusRusanu, it was probably corrupted windows installation.
    – Jelena
    May 10, 2017 at 19:36
23

Had the same error.

Turns out that it was my setting in Region -> Formats -> Format. When it was on English (World) or English (Europe), I would get this error. Setting it to English (United States) solves it.

I'm guessing that English (World) or English (Europe) were new formats with Windows 10, and SSMS is not prepared for it.

6
  • FRENCH Switzerland culture blocked import of a flat data file. Setting English US and worked like a charm. Thanks.
    – eka808
    Mar 3, 2019 at 18:43
  • cool direction otherwise i was trying lot of other trick but only this language format to English (United States) works for me Apr 21, 2019 at 14:35
  • 2
    Some problem here. With English (Belgium) it failed, with Dutch (Belgium) it worked fine...
    – Geert
    Jul 2, 2019 at 20:13
  • Solved my problem, thanks! May 27, 2021 at 5:27
  • Solved my problem also, thanks! Aug 13, 2021 at 11:20
0

No need to change the RegEdit Register Editor.

If you are facing the Error 0xc002f210: Preparation SQL Task 1: Executing the query "Culture is not supported. Parameter name: culture 3072 (0x0c00) is an invalid culture identifier." just set the Regional format to English (United States):

enter image description here

This also works if you are trying to import a flat file to Azure SQL Database

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.