0

enter image description hereHi All,

We have a problem today wherein in Oracle we are trying to execute a package (every morning) and this is the only time we encountered the error (ORA-0114).

Any ideas how to fix this? We have already extended the SYSTEM and TEMP tablespace space.

And the crazy thing is, we tried yesterday and recompiled the package (we are using TOAD) and it worked. But today, it didn't work again even though it was already recompiled (same error).

BTW, line 273 was the part INSERT INTO SELECT statement.

I tried to execute the SELECT statement on the query window, and it also gets the same error.

Thanks !

0

The error is specific to Windows platform, where the file is being accessed by another process, probably non-Oracle processes such as anti-virus, OS backup or something else.

Make sure there is no other non-Oracle process accessing the data file #201 when you are running that procedure.

Resolving ORA-27072 , OSD-04008 and O/S-Error: (OS 33) On Windows Platforms (Doc ID 2016620.1)

Update:

In order to find which application is using a specific file-

  1. Download Handle from here, if you don't have already.
  2. Extract the downloaded .zip file in your drive.
  3. Run handle.exe <path to your datafiles> on command prompt.
  • Thanks for feedback. Yes its running on Windows platform. Is there a way to identify the process accessing the file? – Edgar Allan Bayron May 11 '17 at 4:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.