I am trying to learn how to use RMAN , version is 12.2 Read Oracle documentation.... It talked about setting up a Ghost instance first... Thought I did what it supposes to do, 1. copy password file from source and rename it 2. edit listenor.ora to add a static entry for the Ghost instance 3. edit tnsnames.ora to add an entry for the Ghost instance

but when I tried to do RMAN connect to the Ghost instance

it said ORA-12560: TNS:protocol adapter error

I am not sure what did I miss any help is appreciated.

Thank you

Hi Everyone,

I kind of find the solution myself... anyhow... Oracle Documentation is pretty rough.... but they need to support so many different platforms so it is understandable... anyhow... I meant Ghost instance is like an instance which has nothing but init file and password file and folder structures...

I am in windows env

what I did is use Oracle Database configuration assistant to create a dummy instance with the same feature as the source (no Oracle Auto Naming) then I modify the init file to add the DB_FILE_NAME_CONVERT AND LOG_FILE_NAME_CONVERT parameters, then restart the instance nomount then the RMAN works successfully.... duplicating the instance.... I cannot manually create the "Ghost" instance.

I now will go to next chapter trying to do data-guard....

exact detail steps :

  1. First use Oracle Database Configuration Assistant to create a instance B12C make sure use the same feature as the source instance such as both turn off Oracle Auto Naming

1.5. setup A12C and B12C on both tsnames.ora for both source and destinations server and tested it

  1. modify parameter file add these rows :

*.DB_FILE_NAME_CONVERT=('c:\oracle\oradata\a12c','l:\oracle122\oradata\b12c') *.LOG_FILE_NAME_CONVERT=('c:\oracle\oradata\a12c','l:\oracle122\oradata\b12c')

  1. remove this line from parameter file :


  1. copy the init text file into spfile

  2. restart B12C nomount

  3. run this in dos

rman target sys/xxxxx@a12c auxiliary sys/xxxx@b12c

rman> duplicate target database to b12c from active database using backupset;

  • I see no references to a "ghost" instance in the Oracle 12c docs. What doc are you reading? Since your subject says you are trying to setup an auxiliary instance, are you trying to setup a dataguard environment perchance? Also: "I tried to do RMAN": that doesn't actually tell us the command you used to try to connect. ORA-12560 is a generic error that basically means either your database isn't up or it can't connect to it... of which, there are a great host of blogs out there on this error... – Kris Johnston May 11 '17 at 21:17

You can create manually a dummy instance. On Windows you need oradim to do this. This is documented in the Database Platform Guide specific to Windows:

About Administering an Oracle Database Instance Using ORADIM


oradim -NEW -SID prod -STARTMODE auto -PFILE C:\app\username\admin\prod\pfile\init.ora

After this, you can set ORACLE_SID and log in and start the dummy instance:

set ORACLE_SID=prod
sqlplus / as sysdba
SQL> startup nomount

On Windows, you typically receive this error:

ORA-12560: TNS:protocol adapter error


  • ORACLE_SID is not set properly
  • the windows service that belongs to the instance is not started
| improve this answer | |
  • Good to know, thanks to your info, Balazs, I would try your approach when I have some time. the error message you specified is exactly what I got – user124379 May 15 '17 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.