some time ago I installed SQL server 2016 developer edition on a windows 10 home edition environment (a laptop to be precise) and everything was fine.

then someone - an administrator on the box - decided without telling me, to rename said box.

after that when attempting connection to SQL server we have been experiencing the following error messages:

enter image description here

enter image description here

this is a very similar question to this one:

“The certificate chain was issued by an authority that is not trusted” when connecting DB in VM Role from Azure website

I have been also here:

The target principal name is incorrect. Cannot generate SSPI context. (Microsoft SQL Server, Error: 0)

and I have been using the Kerberos Configuration Manager, which gives me a different error message

enter image description here

I should say that I Am able to connect to this instance of SQL server by SQL server authentication but I want to connect using windows authentication.

just to be clear - this is all a local machine, that does not belong to any domain.

I am not quite sure as how to proceed from here, what I want is to use windows authentication.

The error message related to certificates makes me think about re-issuing certificates here. I am not sure as for how to get this done, or if this is a valid way to go about this situation.

I will not be around this machine for the day, but I will catch up as soon as possible. I will carry on with my research when time permits.

  • 1
    Have you run sp_dropserver, sp_addserver to ensure that the internal SQL name is correct (ie is @@servername different than the machine name?)
    – Nic
    Commented May 17, 2017 at 13:34

2 Answers 2


On connection pop up click on options enter image description here

Then make sure the "Trust server certificate" is checked

enter image description here

  • 2
    It should be noted that this is a WORKAROUND, not a proper solution. The true solution is to deal with the certificate trust issue. Commented Jan 25, 2019 at 23:05

go advanced "options" and put TrustServerCertificate=True to Additional Connection Parameters

  • 6
    How and why does this solve the problem? Commented Aug 10, 2017 at 11:29
  • 3
    it says the client that it can trust the untrusted certificate for the encrypted connection to the server. its untrusted because the root certificate is not installed on the clients machine
    – cyptus
    Commented Jul 27, 2018 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.