0

I'm trying to dump a MySQL (5.7) database of a about 150 GB, out of which most data (about 90 GB) is in a single table. I tried using MySQL Workbench (6.3) to do this through the GUI. The process starts, and most tables finish, but the big ones eventually fail.

I got recommended to use the commandline tool mysqldump.exe instead, and I tried that. This seems to work, but also eventually fails on the big tables, and reports:

mysqldump: Got Errno 28 on write

I'm trying to dump to an external drive with plenty of space.

One curious thing, is the failure always seems to happen exactly when the file in question hits 4 GB (or 3,99GB). I've tried looking around for this, but no luck!

I'm running Windows 10, 64-bit, mysqldump is 64-bit, I have 16 GB of RAM in the system. I don't feel like I should hit any 4 GB limits, but I'm probably missing something very basic?

Hope you guys can help me out!

The command in running to do the dump looks like this:

mysqldump -t -u root -p [database] [table] > J:\table_name.sql

  • What is the filesystem? The file size limit for FAT32 is 4Gb – Philᵀᴹ May 17 '17 at 12:42
  • I feel like and idiot, thank you :) Going to fix this, and see if it works! It most likely does. – Adam Hede May 17 '17 at 13:05
  • @Philᵀᴹ, You where right :) The workbench GUI also works now! Thank you so much! – Adam Hede May 17 '17 at 14:18
  • FYI: MySQL Workbench under the hood also uses mysqldump, so it makes no difference if you use WB or mysqldump in a terminal. – Mike Lischke May 18 '17 at 6:41
  • I had a feeling that would be the case, I just saw somewhere someone recommend trying to go around workbench :) But thanks for the heads-up! The more you know. – Adam Hede May 25 '17 at 14:42
1

The file size limit for a FAT32 filesystem is 4 Gigabytes. You will be hitting this limit.

  • This turned out to be the problem! Changed the file system, and now it works wonderfully! – Adam Hede May 25 '17 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.