5

This problem appears to have been written about quite a lot, and answers posted here too, but I have tried all the suggestions and some of my own to no avail, so please bear with me.

I have Windows 10 V1607, 64-bit. I've used SSMS for a long time, and keep up-to-date with the latest versions, especially now that it is shipped independently, and free, from SQL Server.

When I switched from Windows 7 to Windows 10 on this machine, I installed SSMS V16, and noticed then that there were no 64-bit nodes in SSCM. I didn't think too much of it at the time, and set about creating my 32-bit aliases.

Recently, I changed an old application to 64-bit, compiled and ran it in Visual Studio (2017), and tried to connect to a database. It failed.

I thought it might be that I have not set up any 64-bit aliases, so returned to SSCM to add them. But no 64-bit nodes.

I have seen various suggestions about copying files from a working copy, so I tried that. No difference.

I spotted the latest SSMS V17.1 had just been released, so installed that. It too is missing the 64-bit nodes.

I have tried repairing, reinstalling, turning it off and on again, but still they fail to appear.

Please, does anyone have an insight into why this happens, but more to the point what to do to fix it?

I have SQL Server installed on another machine. I want my application to connect to a database on that machine, remotely. To make it easier to manage the remote database I have SSMS installed locally; in that way, I don't have to use RDP to connect to the server. When I run my application and it connects to the remote database, I want to use an alias, such as 'MyRemoteDatabase', instead of using the IP address and port number directly. In the past, I have run SSCM to create the alias, but my 64-bit applications don't see my 32-bit aliases, which is why I want the 64-bit nodes.

1
  • 2
    Did you ever resolve this? I've got the same issue
    – Jake Smith
    Commented Jan 18, 2018 at 21:55

4 Answers 4

2

Right click the Config Mgr shortcut in the Start Menu, open the file location, change the shortcut Target to:

C:\Windows\SysWOW64\mmc.exe /32 C:\WINDOWS\SysWOW64\SQLServerManager13.msc

The *.*14.msc was my issue.

1

I have no idea what you look for but I guess they may just in front of your eyes.

Here is what I have 64bit Windows, 64bit SQL Server installed.

enter image description here

Maybe you looking for 64bit keyword, they are omitted because it is the default.

1
  • 4
    I don't know how to paste an image, but my image looks like the first six lines of your image. The remaining rows, which are the 64-bit nodes are not present.
    – ckl
    Commented May 26, 2017 at 16:14
1

We ran into this problem because we installed SQL Server 2016 and then the latest version of SSMS (17.9). The problem is that SSMS installed the "SQL Server 2017" folder and configuration tools in the start menu. If you open the config manager for 2017 you only see the 32-bit network settings. You have to open the SQL Server 2016 configuration manager to see everything. Basically the same thing @ericb said - you need to open the config manager that was installed with your server, not the one installed by SSMS.

0

In my case, I was dealing with a SQL 2008 R2 installation. I needed to add Read & Execute Permission for the local Users group to: C:\Program Files\Microsoft SQL Server\100\Shared even though my user account and all groups of which my account is a member had explicit permissions to that folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.