I am unable to start then SQL Server Agent. I am getting the below error message when I tried to start the agent:

The SQL Server Agent service (DB_NN) on local machine was started and then stopped. Some services automatically stop if they are not used by any service or program

  • SQL version: SQL Server 2008R2 Standard Edition(RTM)
  • Windows:Windows server 2008 R2 enterprise

I verified below things, currently SQL agent is running through service account. I changed to local and tried to start. But agent didn't started.

How to fix this issue?

  • 2
    At this point in the troubleshooting process you need to find a better error message. You might something in the windows event logs or the SQL Server log. Check those place and post back any message. Also please post the edition and version of SQL Server
    – Nick.Mc
    Commented Jun 1, 2017 at 5:30
  • 1
    Did you change the service account using the SQL Server Configuration Manager? This is required in order to ensure that proper permissions are set on the required directories, files and registry settings. Otherwise the service may fail to start.
    – John K. N.
    Commented Jun 1, 2017 at 6:54

1 Answer 1


After reading your posting I understand that when you establish USBLAN_LDR service on windows server 2008, system prompt an error message.

According the information what you provided right now, it’s hard to determine what cause this issue, you may like to post more information about your environment (Event log ,Other System prompting etc… ).

Please check if it worked with assign a Local System account instead of Local Service account to run this service.

  • Open service MMC snap-in. ·

  • Right UBSLAN_LDR service , and click “properties”.

  • Click “Log on” tab , and assign a local account for running this services.

Seems this issue related to a third party software, I suggest to consult software vendor for future troubleshooting.

Please understand that I don't mean to bounce you between different solution provider as I am fully aware how time consuming this can be. However, they really are in a better position to be able to assist you with this issue as they may have experienced similar issues.

  • I am unable to find UBSLAN_LDR service in MMC console
    – kumar
    Commented Jun 5, 2017 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.