0

I am not getting the right problem what might be making the mongodb shell not getting initiated.
Here is the gist of my log of MongoDB: https://gist.github.com/JafferWilson/c6f964060bc27014d25e22066ed5f292
I do not know why it is showing the Index Build 2% or 30%.
Kindly, suggest me what might I do to initiate my shell and starte performing. I am running out of time due to this delay. PLease suugest me.

1

You have managed to kill your mongod middle of index build.

found 2 interrupted index build(s) on datastalk.stalk

Build of first index ({ v: 2, key: { _id: 1 }) didn't take long. Second index ({ v: 2, unique: true, key: { EMAIL: 1.0 }, name: "EMAIL_1", ns: "datastalk.stalk" }) is taking longer.. And at point of 35%, system got access violation when reading memory address 0x0000005648530000

Do your machine have enough memory and memory DIMMs are good?

You can try to solve this problem with wiredTiger command line tools. Use dump to get your data from database to file, re-create your mongodb instance (remove all files from dbpath OR point your dbpath to other directory and restart mongod) and then import data back to database (re-creating needed indexes)

5
  • My system have 28 GB RAM. Jun 2 '17 at 9:06
  • My configuration includes 32 GB RAM where 4GB is reserved for system usage. Jun 2 '17 at 9:25
  • Can you run memory test? Because access violation on memcpy is something what you don't want to see.
    – JJussi
    Jun 2 '17 at 11:55
  • Sure I will run memory test once. But still I am doubtful whether the problem is due to the RAM. Jun 3 '17 at 1:57
  • @JafferWilson added wt tool information to answer
    – JJussi
    Jun 3 '17 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.