So I was upgrading 3 databases from to Two of them went just fine. Long story short for the last one, the upgrade was interrupted near the end (let me know if more details are necessary). Tried a couple of things, then just decided to restore because I have never manually finished upgrading a database before. It would not have been time efficient.

Restored, ran through the steps again to prepare for an upgrade, run the upgrade assistant script for the 3rd database. The first screen correctly states that the Oracle Home =, but after hitting next was told that the database needed to be mounted before the upgrade began. Database was in startup mode. So I clicked next again to see if I would get a different message. The next message I got read,

"The Upgrade Assistant filed in bringing up the database [name]. Oracle >Home /oracle/product/ obtaining from the >file /var/opt/oracle/oratab was used to connect to the database. Either the >database is not running from Oracle Home /oracle/product/ or the >correct Initialization Parameter file (pfile) was not found."

It then prompted me to give the path for the init file. But before that, I checked the oratab; it correctly stated for that database. Went ahead with the giving the path to the init file, returned the same error without the option of choosing the init file. Tried bringing over a good copy of the pfile, changed the parameters I needed to change, deleted the spfile and created a new one from the pfile, then tried again with the same results.

So I am guessing that someone along the line during that interrupted upgrade, some reference that I don't know about was changed that is telling the Upgrade Assistant that the original database Oracle Home is in instead of what the oratab and listener actually say, Any insight to what I need to change here would be greatly appreciated as I do not want to do another restore without a plan of what I would do differently than the last time I did so.

  • 1
    Can you manually start the database after you restored it? Are there any messages in the alert log?
    – jmk
    Jun 13, 2017 at 6:44
  • 1
    It's for reasons like this that I upgrade manually, even though oracle recommends the UA. When it fails, you sometimes don't know how to restart. When the manual upgrade fails, you always have options.
    – sandman
    Jun 13, 2017 at 11:17

1 Answer 1


So I found the solution after much investigation and trial and error. I deleted the .log files from $ORACLE_BASE/cfgtoollogs/dbua/logs. After restarting the session and the UA, it worked fine. I'm not entirely sure WHY that worked (which bugs me), but there's the answer. Hopefully this will be helpful to others in this situation.

Thanks to those who commented on my question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.