I'm installing Oracle 12c on Windows 10 Pro and receiving the error message:

"PRVF-3919 : Failed to retrieve value of environment variable "PATH""

I've read through several similar questions and followed recommended procedures:

  1. I'm executing the installation setup as Admin
  2. I renamed Path to PATH
  3. I counted the existing chars in Path (834, well under the 1023 limit)
  4. I deleted unnecessary Path statements to reduce size
  5. I deleted all entries in Path to start fresh.

All to no avail. I'm still getting the same error message. Does anyone have any other ideas or suggestions?

Thank you, mfc

  • Did you reboot after modifying the PATH variables? Especially critical for the SYSTEM environment variables. How does your user's PATH variable look like? Did you install Oracle with "Runas Administrator..."?
    – John K. N.
    Jun 20, 2017 at 14:21
  • ... don't delete the entire PATH variable, that's going to cause many more problems than it will solve. I would recommend installing Oracle to an oracle home that is no more than a few directories deep, ideally something like C:\oracle\12c\x64 as this won't append too many more characters to the Windows PATH variable. Jun 20, 2017 at 14:31

2 Answers 2


Thank you all for your answers. I believe @John Eisbrener had the correct answer. I placed the installation in a root "C:\Oracle" directory instead of accepting the default User Directory installation. It installed without issue after that.

Thank you all for your responses.


I was searching for this error for a while and have not found any proper response why this was happening on my machine. This is an Oracle Support Article in the topic, which was applicable to my case: Oracle Database/Client Installation raises PRVF-3919 ON WINDOWS 10 Build 1703 (Doc ID 2307844.1)

The issue is that the installer cannot access the PATH variable and it is stupid enough to stop the install because of that (unless you force to bypass all checks). A Microsoft bug caused this: https://blogs.msdn.microsoft.com/winsdk/2017/08/24/openservice-fails-on-a-service-marked-for-deletion-on-windows-10-version-1703-os-build-15063/ Additionally I found that this happens also with teh installer.

The bug is fixed in the Windows 1709 version, where the Oracle installer should run fine. Hope this helps others struggling with this issue on the impacted OS version, trying to tweak the variable etc. etc., all in vain.

  • I tried with all the options but no luck. I was trying to install 12c in windows 10. I just select skip all option and continue with the installation and it was successful at the end.
    – S.Roshanth
    Aug 25, 2017 at 10:12
  • Thanks for the tips. I am in Windows 10 build 1803, and still need to change the variable name from Path to PATH to get the installer working.
    – Yida
    Aug 21, 2018 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.