0

When i tried to install percona-xtrabackup on Master server db
yum install percona-xtrabackup-24

I got this error:
file /etc/my.cnf from install of Percona-Server-shared-51-5.1.73-rel14.12.625.rhel6.x86_64 conflicts with file from package mysql-community-server-5.7.18-1.el6.x86_64

How to solve this problem? -CentOS 6.5 2.6.32-431.el6.x86_64

  • remove? mysql-community is use for mysql server all process base on it. after remove mysql service will down right? – BongSey Jun 23 '17 at 8:12
  • Oops sorry I didn't see xtrabackup installation. – Mannoj Jun 23 '17 at 8:16
  • Can you try doing via rpm? rpm -ivh percona.com/downloads/XtraBackup/Percona-XtraBackup-2.4.4/… – Mannoj Jun 23 '17 at 8:27
  • i have tried but unluck! – BongSey Jun 23 '17 at 9:04
  • 1
    I can help you as a work around you may give it a try. Install the package on some other server and take innobackupexec file under /usr/bin to db server if you are planning to do with innobackupexec backup module. Execute a backup and see how it works. – Mannoj Jun 23 '17 at 11:31
2

try:

  1. Download mysql-community-libs-compat from mysql (https://dev.mysql.com/downloads/mysql/)

    rpm -i mysql-community-libs-compat-5.7.17-1.el7.x86_64.rpm
    
  2. Install perl-DBD-MySQL

    yum install perl-DBD-MySQL
    
  3. Install percona-xtrabackup

    yum install percona-xtrabackup
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.