1

I get the error message displayed in Power BI Online when using an enterprise gateway connected to an on-premise SQL Server

Unable to connect: We encountered an error while trying to connect.

Details: Microsoft SQL: A connection was successfully established with the server, but then an error occurred during the login process. (provider: ssl provider, error: 0 - The signature of the certificate cannot be verified)

I have the Login credentials (SysAdmin) on server.

What is the cause of getting Login error? Any suggestions and resolution steps?

  • Do you use ssl encryption? – sepupic Jun 23 '17 at 16:23
  • I have no Idea about SSL, who is talking care of this DBA or network team? – CR241 Jun 23 '17 at 16:36
  • 1
    When you use your Power BI, did you check "encrypt connection"? – sepupic Jun 23 '17 at 16:40
  • @sepupic Thanks. Yes, I did uncheck "Encrypt Connections" option. This link helps me solve this: community.powerbi.com/t5/Desktop/… – CR241 Jun 23 '17 at 18:17
3

I found resolution for this error:

By default, the Encrypt connection check box is selected to signify that Power BI Desktop connects to database using an encrypted connection. If a connection to your SQL Server is not established using an encrypted connection, that Power BI Desktop prompts to connect using an unencrypted connection.

Once you click OK, it will be directly prompted to turn off encryption. Or you can go to

File->Options and Settings -> Data Source Settings, choose your SQL Server data source and select Edit and uncheck "Encrypt Connections" option.

In addition, when we connect to SQL Server in Power BI Desktop, need to select the authentication mode to connect to the SQL Server database.  

1) Windows: This is the default selection. Select this if you want to connect using Windows authentication.  

2) Database: Select this if you want to connect using SQL Server authentication. After you select this, specify a user name and password to connect to your SQL Server instance.

Note: I know it's foolish and so simple but works for me anyway @sepupic Thanks for useful comment.

1

Go to File > Options and Settings > Data Source Settings > (select your data source) > Edit Permissions > Edit > Database, and enter here your User name and Password

enter image description here

  • This fixed it for me on the desktop – MikeAinOz Mar 7 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.