0

I have this configuration:

enter image description here

I have two track inserts/updates/deletes on user table and save those changes to user_events table but I can't create new tables or triggers on master.

I have setup slave and it perfectly replicates data from user to user table. However triggers on slave are not fired. Tried binlog_mode MIXED and STATEMENT. Neither worked.

  • Please help me to get your question rightly. You have user table in Master and you have a trigger on slave so whenever you run insert on user it initiates the triggers and inserts on user_events table on slave. But in your case it isn't working. Is this is your design? Correct me if am wrong. I'm sure that it has to work in SBR. Coz I had similar setup in one of our systems. There should be something wrong in trigger syntax. Can you recreate the setup in fiddle? Or share the create commands of user, user_events and trigger ? – Mannoj Jun 29 '17 at 3:09
  • You should have be doing writes on the Slave, other than through replication. – Rick James Jul 6 '17 at 4:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.