0

I've set up a Postgres-XL cluster using this recipe:

GTM:
hostname=host1
nodename=gtm

Coordinator:
hostname=host2
nodename=coord1

Datanode1:
hostname=host3
nodename=datanode1

Datanode2:
hostname=host4
nodename=datanode2

When I ran a load test against it, the GTM would fallover. I tweak settings until the GTM didn't fall over but only reported errors - thus kept on working after the load test.

I the added a GTM Proxy. I did not do init all but rather only init the proxy. When I restarted the cluster, the GTM reported that the GTM proxy was up and running. When I looked at the GTM proxy's log, it looked like it started up and was connected.

But when I ran the load test again, I got the same result with no log entries for the GTM proxy. Thus it seems like the GTM Proxy didn't pick up the load processing as I expected it to do.

I don't know how to trouble shoot this. Any pointers on where to look next?

(I don't know what extra info to post here)

0

This is known bug/feature: pgxc_ctl does not know which proxy should be used by each coordinator / datanode (it does not assume that it is supposed to use a local one).

GTM proxy does not 'pick' the config; you need to instruct others to use the proxy.

You can fix it manually by editing postgresql.conf located in data directories for your datanodes and coordinators.

Find gtm_host and gtm_port and replace real GTM values with IP and port of your proxy. Or you can add these lines to the end of the file if this makes your scripts easier. Reload datanodes and coordinators to update their config (pg_ctl reload -D /data/directory/path)

Ideally you should have a proxy configured on every physical host, and instruct your datanode and coordinators to use the local proxy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.