1

So I found this question and believe this is related. SQL Server Management studio slow connection or timeout when using Windows Authentication

If I extend my timeout to 30 seconds I get SSMS connected but everything is terribly slow! The application is extremely slow/timing out when debugging.

They mention adding an entry to the hosts file to bypass DNS lookup. This is a local dev db running on my machine. What would I add to the hosts file to eliminate these DNS issues??? Servername = "ROG-DREAM-MACHI\SQLDEV".

I'm a db noob. Plz help. :(

  • Should also note, that I'm working on a different network right now. I never had these issues at home or in office. Nothing else has changed. – Hardycore Jul 4 '17 at 19:43
  • Are you connecting as a local user or domain user? – Alex Jul 5 '17 at 3:36
  • Local. This is my personal laptop. Not added to any domains. – Hardycore Jul 5 '17 at 14:19
  • Another note. Once connected, the application I'm debugging seems to work fine. As long as I've set the timeout to 30 it'll connect (takes longer than it should) but once connected it runs as it should. – Hardycore Jul 5 '17 at 14:25
  • Small trick: Open Internet Explorer Go to Tools -> Internet option Open the "Advanced" tab Uncheck "Check for server certificate revocation (requires restart)" This trick is only effective if the computer where your SQL Server Management Studio is installed is NOT connected to Internet. – CR241 Jul 5 '17 at 16:42
3

Your DNS entry in the C:\Windows\System32\drivers\etc\hosts file will be:

ROG-DREAM-MACHI   127.0.0.1

You'll need to use Notepad with administrative rights, to be able to make any changes to that file.

(However, I'm voting to close this question as a duplicate of the one you posted.)

  • OMG Thank you. I was putting the full computer name thinking that sql had simply cut it off. I'm dumb, your smart, THANK YOU! – Hardycore Jul 6 '17 at 15:19
  • There's a legacy "feature" where NetBIOS only cares about the first 15 characters of a machine name. – Randolph West Jul 6 '17 at 18:40
  • Solved my problem, after almost a week of struggle. Shame on you Microsoft. – Saeed Neamati Sep 27 '19 at 12:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.