0

This has happened a few times before and on all of those times I was not able to find an answer on the internet and I've had to completely uninstall MySQL and reimport the database from a backup. Although right now there's a little more than 1 billion rows so that's not something I see as an acceptable solution at this time.

In the processlist there are four queries showing as "sending data" and all of them are killed. Below that there are about 100 more listed as "statistics" which cannot be killed either.

Is there a way I could fix this without reinstalling MySQL?

Edit: Ubuntu 16, mysql newest

  • Have you tried turning it off and back on again? – apokryfos Jul 9 '17 at 6:57
  • If I do that from previous experience I would have to forcekill the proccess and after that it will never turn back on again. At one point there was a file I was able to delete to start up again, but I can't recall the name or find it in the mysql folder – Wallfull Jul 9 '17 at 6:58
  • If its running as a service you can try stoping the service service mysql stop works in Ubuntu otherwise it might be in/etc/init.d. Try stopping it and see if it complains, then update the question with what message your'e getting. If stopping works but starting does not, update the question with the message that it shows when it can't start. At any rate there's not enough to go on in this question. – apokryfos Jul 9 '17 at 7:00
  • Still doesn't work and only causes mysql to be unable to be connected to – Wallfull Jul 9 '17 at 7:07
  • Start it again after stopping it – apokryfos Jul 9 '17 at 7:07
1

For future refference for myself and anyone else with this issue, run "pkill mysql", move "ibtmp1" (like 90G) inside of /var/lib/mysql to another location, then start mysql again.

  • This may warrant a bug report at bugs.mysql.com . – Rick James Jul 10 '17 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy