1

I did the migration from PostgreSQL 9.4 to version 9.6, but now the stream replication is not working, it stopped replicating.

Script followed:

  1. installation of postgres 9.6 on the three servers (master, slave1 and slave2).

  2. running pg_upgrade on the three servers

The message that appears in the slaves server database log is as follows:

2017-07-13 19:01:46 -03 [25188]: [1-1] user =, db =, client =, appname = FATAL: databa System identifier differs between the primary and standby

2017-07-13 19:01:46 -03 [25188]: [2-1] user =, db =, client =, appname = DETAIL: The p Rimary's identifier is 6442320581826004577, the standby's identifier is 64423219 34563538204.

How do I resolve this problem?

  • I think you are supposed not to run pg_upgrade in the slaves. Read pg_upgrade procedures again. – ypercubeᵀᴹ Jul 13 '17 at 22:14
  • 1
    "running pg_upgrade on the three servers". How exactly was pg_upgrade run? With what parameters (in each installation)? Were the original instances stopped? In what order were the steps of the whole procedure taken? – ypercubeᵀᴹ Jul 16 '17 at 13:47
  • Hello Good Morning Thanks a lot for the help. – Jose Carvalho Jul 19 '17 at 16:02
  • If you want to go forward, without waiting for a complete answer to the issue - and assuming that your master has been upgraded and works properly in 9.6 - you can always setup replication (using 9.6) to the slaves from scratch (scraping or not the existing malfunctioning setups). – ypercubeᵀᴹ Jul 19 '17 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.