1

I'm trying to make an SSL supported connection using MySQL Workbench 6.3.9.
My OS is Windows 10 x64 and I have installed MySQL Server 5.7 x64 with OpenSSL-1.0.2L (Win64 version).
I made a non-SSL connection without any problem but when I am trying to make an SSL connection I always get this error: 'SSL is required but the server doesn't support it (2026)'
my.ini file contains these settings:

[client]
ssl-ca = "C:/vcerts/ca-cert.pem"
ssl-cert = "C:/vcerts/client-cert.pem"
ssl-key = "C:/vcerts/client-key.pem"
ssl
ssl-capath = "C:/vcerts"

[mysqld]
ssl-ca = "C:/vcerts/ca-cert.pem"
ssl-cert = "C:/vcerts/server-cert.pem"
ssl-key = "C:/vcerts/server-key.pem"
ssl
ssl-capath = "C:/vcerts"

At MySQL Workbench, after SSL Wizard's certificate generation, the SSL certificate settings are: enter image description here

Any suggestions?

2
  • Have you restarted the MySQL server process after configuring SSL? – Philᵀᴹ Jul 18 '17 at 9:13
  • @Philᵀᴹ MySQL service is down at the moment. The error appears when I'm trying to start the server. I tried reboot and a clean re-install but the problem persists. – Zerthimon Jul 18 '17 at 9:29
0

I managed to solve the problem by editing my.ini, step-by-step according to mySQL SLL setup documentation. SSL settings inside my.ini should be:

[client]
ssl-ca=C:/vca/ca-cert.pem
ssl-cert=C:/vca/client-cert.pem
ssl-key=C:/vca/client-key.pem
[mysqld]
ssl-ca=C:/vca/ca-cert.pem
ssl-cert=C:/vca//server-cert.pem
ssl-key=C:/vca//server-key.pem

I guess the problem was that server understands "\s" (or "/s") as "space". So the last 2 server lines looked like:

ssl-cert=C:/vca/ erver-cert.pem
ssl-key=C:/vca/ erver-key.pem

According to server's logic. Plus configuration path/filename must be the same as windows service initialization path.

Configuration path/filename at mySQL Workbench: enter image description here

Configuration path/filename at MySQL57 service:

"C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe" --defaults-file="C:\ProgramData\MySQL\MySQL Server 5.7\my.ini" MySQL57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.