0

I have a cluser of mongodb of 3 nodes: After increasing the max-openfile-count of the linux system user, I tried the following cluster startup commands after a rebooting the linux system without shutdowning mongodb cluster normally.

# log in each node:
1, /var/opt/mongodb-linux-x86_64-rhel62-3.4.5/bin/mongod -f /data/mongodbtest/config/mongo.conf
2, /var/opt/mongodb-linux-x86_64-rhel62-3.4.5/bin/mongod --maxConns=20000 -f /data/mongodbtest/shard1/mongo.conf --nojournal
3,-- /var/opt/mongodb-linux-x86_64-rhel62-3.4.5/bin/mongod --maxConns=20000 -f /data/mongodbtest/shard2/mongo.conf --nojournal
4,-- /var/opt/mongodb-linux-x86_64-rhel62-3.4.5/bin/mongod --maxConns=20000 -f /data/mongodbtest/shard3/mongo.conf --nojournal

when I run the step 2, the process stucked with following message: enter image description here

I tried to delete the mongod.lock file in " /data/mongodbtest/shard1/data " and retry the process. But the problem still exists.I don't know how can i fix this.

  • 1
    FYI - it's better to copy the actual text of an error message and paste that into your post, rather than a screen shot. – RDFozz Jul 24 '17 at 15:09
0

Without knowing what is content of /data/mongodbtest/shard1/mongo.conf, it's look like you don't have --fork (in config file processManagement.fork:true) set up. Parameter moves the process to background.

BTW, what is reason to --maxConns parameter?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.